The new and improved Saskatoon Techworks wiki, powered by DokuWiki.

This is a rough, jot-note version. Feel free to flesh it out, add screenshots, or plain fix it.

To cut a solder stencil into a laser transparency:

  1. Add a section to your CAM job in Eagle. Output type should be HPGL and the only layer selected should be tCream. I'd suggest a filename of %N.plt
  2. Run the CAM job.
  3. Take the Project.plt file to the laser computer.
  4. In SmartCarve, create a “New” document.
  5. File→Import, Select your .plt file.
  6. Choose 1016dpi
  7. Modify→Scatter Group
  8. Modify→fill, Direction: X Single, 508, 0, CHECK “Delete Contours”, OK
  9. Set velocity to 40 and power to 1%
  10. “Carve Out”

Clean up the rough edges with wet fine emery paper. I used 1000 grit.

To use, I build up a “frame” of unpopulated boards around the board I'm soldering. Tape them down. Position the stencil and tape it down. I deposit a small amount of paste on the top of the stencil, then use a metal scraper to squeegee it across the board. It might take a bit of touchup if the paste missed any holes. Carefully peel up the stencil and remove the board. I find I need to clean the bottom of the stencil with isopropanol after every three boards.

Carefully place all SMT components on the board. Then “bake” the board in the reflow oven. Our oven is pre-set for a Tin-Lead profile. Plug it in. Place your board as near the centre of the oven as possible, then press the right button. At the peak temperature, once the heat turns off, open the door to allow faster cooldown. Watch the temperature! It's too hot to handle for longer than you might think.


Erik's smt stencil etching method (more involved, but optimized for quicker etching time)

Steps 1-6 as before

  1. select all→right click→clone→3columns,1row
  2. select Leftmost board, edit width to be 0.1mm (toolbar on the left) (make sure “lock” aspect ratio is OFF)
  3. same as above, but with Rightmost board
  4. select all→right click→Scatter Group
  5. select all→right click→fill, Direction: X Double, 508, 0, CHECK “Delete Contours”, OK
  6. zoom in to a small pad to check dpi setting - if lines are too far apart to get all the detail, increase scan dpi - if dpi is very high, it will take longer to etch
  7. if you decreased the dpi you may have to unfocus the laser and increase the power
  8. set velocity to 800 (it will go as fast as it can) and power to 30%
  9. carve out

Gerber to DXF (New, even more complicated workflow)

Okay, but I have a Gerber file (that someone gave me, so, no, I can't re-export from Eagle/KiCAD) and your laser takes DXF and I can't find a free Gerber to DXF converter. What do I do?

Simple! (Not really, but it seems to work)

  1. Open the GTP file in Gerbv
  2. Export as PNG, 1016 dpi (this is arbitrary and is a leftover from a previous attempted workflow)
  3. Load PNG into GIMP
  4. Set DPI in Image→Print Size. Take note of dimensions in mm
  5. Colour→Invert
  6. Colour→Threshold (about 3/4)
  7. Select→By Colour, click black
  8. Select→Shrink Selection (5 seems to be good)
  9. New Layer, white background
  10. Fill (whole selection) with black
  11. delete original layer
  12. Export as PNG
  13. Load PNG into Inkscape
  14. Trace Bitmap
  15. delete bitmap
  16. Note dimensions in mm
  17. save as DXF
  18. Load into Smartcarve
  19. Set the dimensions
Gerber to DXF (This one failed with 45 degree rounded-end pads. gerbv totally screwed up the export)

Okay, but I have a Gerber file (that someone gave me, so, no, I can't re-export from Eagle/KiCAD) and your laser takes DXF and I can't find a free Gerber to DXF converter. What do I do?

Simple! (Not really, but it seems to work)

I did this all on Linux, so if things work different on Windows, please let me know.

Use gerbv to open the gerber file. Look at it. Use the Measure tool to measure some easy-to-repeat dimension. Write that down. In gerbv, there is an export option. Export the file as SVG.

Open that SVG file in Inkscape. Save it as a “Desktop Cutting Plotter (AutoCAD DXF R14) (*.dxf)” file. (My Inkscape had a different DXF option, but it didn't work for this.) On the dialogue that pops up, make sure to select “mm” as your base unit. I also used LWPOLYLINE line output.

Now, open that DXF in LibreCAD. (This step might not be necessary, but follow along for now.) Remember that dimension I asked you to measure? Measure it again. For some reason, whenever I do this, my drawing ends up at exactly 80% scale. Scale it up by a factor of 1.25. Save it. Now, take that file to the laser. (You could probably do the scale in SmartCarve if you know, for a fact, that it's out by that factor. I used LibreCAD here because I knew I could use the dimension tool better than in SmartCarve.)

Print/export
QR Code
QR Code smtstencil (generated for current page)